Android push registration failed

Manuel, thanks for the great service & apps!

I’ve been getting this error message lately whenever launching the Android app, and I am not seeing any push notifications anymore. In Android settings, the app has notification permissions (as far as I can tell). It was working before, but I may have done some system updates since then which have changed the permissions somehow. Currently running Android 13 on Samsung Galaxy A53 (SM-A536U1/DS). I have tried app uninstall/reinstall and resetting permissions, no change in behavior. Would appreciate any ideas to try and fix this problem.

Unfortunately I don’t have a physical Android 13 device here to test. However, I’ve just tried the latest HamAlert app version on an Android 13 emulator with Google Play Services, and push registration worked fine there. So I’m not sure what to suggest, given that you have already tried reinstalling the app. Perhaps the following sequence might help:

  • Deinstall the app
  • Log out from the Play Store
  • Reboot the device
  • Log back into the Play Store
  • Reinstall the app

Thanks for the reply! I have figured out the root cause of this problem–it was a VPN issue that was causing some of the background requests from the app to be blocked. Everything is functioning normally again now!

1 Like