Can't LogIn using Android App

Very recently I’m unable to log in using the Android app. I can log in at (using the same cell phone.) I’ve been using HamAlert on this cellphone for over a year with no issues. Any idea what might be going on? I’ve tried rebooting the phone. No help.

Update: It appears I am logged in via the Android app because I am getting notifications on the phone. However, when I open the app I’m presented with the log in panel. When I enter my credentials nothing happens, perhaps because I’m actually logged on. But, I can’t get rid of the log in panel. I’ve stopped the app , but when I start it back up, I’m again presented with the log in panel.

Mike, NE8P

Try deleting and reinstalling the app.

Did that, but still have the same issue. When I open the app I get the “Allow HamAlert to send you notifications?”, to which I click “Allow”. Then I get the LogIn panel. When I enter my credentials, nothing happens. Btw, the three links below the LOGIN button do work.

Mike, NE8P

Sometimes a cache wipe on Android helps, if apps show weird behavior.
The procedure varies from vendor to vendor.

Cleared cache and memory several times to no avail. Funny thing I opened app this morning after it being closed overnight (and, I think I’m not logged in because I’ve been getting the log in panel every time), and I’m greeted with a list of spots! So I logged off hoping that I could log back on and all would be well. Alas, after logging off, the log on panel displayed and when I tried to log on, I get the same non-responsive behavior I’ve been seeing for the past few days.

I also reset my password, but that did not help the situation any. It really looks to me like I am logged on via the phone app, but can’t seem to log off. That may be why the log on process appears to do nothing. (I am already logged on.)

Mike, NE8P

Resolution (?): This appears to be a case of very, very slow response when using the app. If I wait long enough (~one minute) the app will respond.

Presently, the app generally responds quickly, but sometimes it doesn’t. I don’t know why. My wi-fi speeds are quite fast, and all other apps, programs and devices in the house work fine. The cell phone works normally in all other aspects as well.

So I’m able to continue using this fine app. Just need some patience every now and then.

Thanks & 73,
Mike, NE8P

That’s a strange issue, which I haven’t seen or heard of before, and I have no idea what could cause the app to lock up for a minute and then continue as normal.

Well, if there’s one thing that I’ve learned about Android phones, then it’s that there is an almost infinite number of permutations of manufacturer, model, OS version, add-on software like firewalls, VPNs etc. – all of which can influence how a particular app behaves.