Different password rules for iPhone App? -- no "$$" in the password?

I’m a new Ham Alert user. I registered and setup my new account for Ham Alert using the website. I confirmed via the link in the email, and logged into the website with my chosen password.

I was completely unable to log into the iPhone app with that password. I tried a couple times, uninstalled the app, reinstalled and tried again. I logged out of and into the website a few times and the password worked for the t website. But not for the iPhone app. I even typed the password into a note app on the iPhone and pasted it into the app login page to check for fat fingering.

My password had two consecutive dollar signs in it (“$$)”. I changed my password on the website to one without the “$$”, logged out and logged back into the website. I was then successfully able to log into the iPhone app with my new password.

I’ve gotten past the problem and can now use the iPhone app. Just wondering what the weirdness was all about - was it a timing issue with a new account? Some code in the iPhone app that doesn’t handle passwords with “$$” in the middle of it?


I tried to reproduce this, but passwords with $$ in them are working fine for me on the HamAlert website and in the HamAlert app.

HamAlert hashes passwords with bcrypt for storage, so there should be no restrictions on the allowed character set.

73, Manuel HB9DQM